Yamaha PSR170 - Output Works - No Input - Help please!!!

Discussion in 'General Sequencing' started by KnudoW, Sep 21, 2004.

  1. KnudoW

    KnudoW New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I know this is a common question but I cannot get it to work... :(

    I have a Yamaha PSR170, Windows XP and Realtek AC97 Soundcar.

    When I plugged my keyboard to my PC the MPU401 driver installed

    Well, the thing is, if I open a midi file, I can hear it in my Yamaha Keyboard but... I cannot record songs from it!!!

    I've tried a lot of different programs but I get the same results: Output Works, no Input Signal... what can I do??

    I use a normal midi cable plugged in the Joystick thing in my sound card.


    Please, could someone help me???
  2. midiprog2000

    midiprog2000 New Member

    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    0
    Hi KnudoW,

    Only one ? You need two cables: from the PC midi out to the PSR midi in, and from the PSR midi out to the PC midi in.

    It looks like you forgot the the cable from the PSR out to your PC.

    Kind regards,
    Alain
    www.mididesign.be
  3. KnudoW

    KnudoW New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    No, no, I haven't explained properly... From the Joystick Plug 2 cables go to Midi In and Midi Out in the Keyboard.

    I forgotted to say that when I used it a long time ago in my old computer, with windows 98 and a Sounc Blaster 16, it worked.
  4. midiprog2000

    midiprog2000 New Member

    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    0
    Hi KnudoW,

    Ok, now it's a matter of eliminating the possible causes of the problem.

    1) Switch the midi cables. If there is now an incoming signal into the PC, but no incoming signal into your PSR, the midicable going from the PC midi out to the PSR midi in needs to be replaced.

    2) If the cable is not the problem, check the PSR midi ports.
    Try connecting the PSR midi out to a midi module, and check if you have an incoming signal in the midi module.
    If you don't have another midi module, you may check the ports as follows:
    - Switch the PSR "local switch" to "Off" (see your PSR manual, look for "local switch"). You can't hear anything now if you play on your keyboard.
    - Connect a midi cable from the PSR midi out to the PSR midi in (yes, you connect the PSR with... the PSR ;-).
    - Now you should be able again to hear something if you play the keyboard. If not, the PSR midi out port is not working.

    3) Check your PC midi in port by connecting another midi keyboard to it. If you are now able to record midi signals, you know all hardware is ok. If not, it's your PC midi in port that is not working, or a software problem. Before replacing your soundcard (replacing the midi port), first check for software problems.

    4) Download MidiOx at "http://www.midiox.com/"
    Install the software, and open the program.
    Go to "Options --> midi devices". Select the midiport of your soundcard, and click "OK" . Now play on your keyboard. You should see the signals coming in now.
    - If you do, the problem is definately to find in you sequencers midi settings.
    - If you don't see incoming signals: uninstall and reinstall the drivers of your soundcard, and check again with MidiOx.

    5) If you still have no incoming signal, replace your soundcard

    Well, I hope this will solve your problem.

    Kind regards,
    Alain
    www.mididesign.be
  5. KnudoW

    KnudoW New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I've just tried it on my old computer and it works, so I think It doesn't work because of the new computer's sound card....

    Well, mission acomplished, thanks for your help

Share This Page